¿com.sun:tools:jar:1.5.0?

Puede parecer una tontería, pero yo he tenido este problema. Haciendo el maven eclipse:eclipse de un nuevo proyecto se me queja de esta dependencia:

com.sun:tools:jar:1.5.0

Y claro, esa dependencia no existe en ningún repositorio. ¿Cuál es el problema? El problema es que Eclipse estaba usando para compilar la JRE, no la JDK. Para resolverlo nada más simple que decirle que use el JDK:

Windows -> Preferences -> Java -> Installed JRE’s -> Add

Y añadimos una con nombre JDK que apunte a la ruta del JDK y la marcamos para que la use por defecto. Cuando añadamos cualquier servidor Tomcat con usar el “default workbench JRE” tenemos suficiente.

Comentarios

Comments are closed.